Category Archives: Cisco

OSPF Type-4 LSA

Have you ever questioned your self, why on earth do we need OSPF type-4 LSA ? well, you are not the only one. Welcome to this blog post where we’ll try to discover the actual worth of that LSA.

First let’s examine the below graph, where we have a basic implementation of multi-area OSPF. R1 RID is 1.1.1.1, R2 RID is 2.2.2.2, R3 RID is 3.3.3.3, and we have network 200.200.200.0.24 redistributed to OSPF area 1 by area 1 ASBR; R1.

Capture

We’ll start by examining the contents of the Link State Data Base (LSDB) of R3 for the external prefix 200.200.200/24;

Capture

Capture

When we look extensively at the type-5 LSA of prefix 200.200.200/24 in the LSDB of R3, we can see that it has an advertising router of 1.1.1.1 and a FW addr: 0.0.0.0.

The 1.1.1.1 is the RID of the advertising router, while the forwarding address is a way to that can be used to route traffic in another direction than to the router that originated the LSA. Having a value of 0.0.0.0 as the FW addr essentially tells other routers to forward packets for that destination to the router that advertised the LSA.

However when looking closely, we can see that R3 LSDB also has a type-3 LSA for 1.1.1.1/32,  so the question that popped out of my mind was “If there is a valid reachable type-3 for 1.1.1.1/32, then why do I need Type-4 LSA?”.

After taking a while looking into the issue I realized what went wrong. Well, I made a mistake, the 1.1.1.1/32 summary LSA was not the same 1.1.1.1 that advertised the external LSA. So what is the difference ?

Here’s were everything starts to get clear, we all network engineers have the convention that OSPF RID is driven from the highest loopback interface IP address present on the router and in case of the absence of loopback interfaces, the highest physical interface IP address well be chosen as the OSPF RID of the router, here is the catch, OSPF RID is a node-identifier. It usually uses an IPv4 address format, but it is an ID and does not need to match any interface present on the router.

Ok then, let’s try something, we’ll change the IP address of the lo0.0 of R1 to 100.100.100.100/32 and see what happens.

Capture

If we examined the external LSA of prefix 200.200.200.0/24 we notice that it still has the 1.1.1.1 as an advertising router, but wait, where is the LSA type-3 that was advertising 1.1.1.1/32, it’s no longer there and was replaced with 100.100.100.100/32 that is the new lo0.0 address of R1 that was already included under protocol ospf hierarchy of the configuration stanza. So the only way to reach the RID of R1 1.1.1.1 and consequently the external prefix 200.200.200/24 is by following the information contained in the ASBRSum LSA.

As you notice, our small lab was fruitful and we can conclude the following:

  • Routers in other areas see a Type-5 with a meaningless RID. They might have a type-3 prefix that looks like the ASBRs RID, but this doesn’t help it find the ASBR.
  • The type-4 LSA generated by the ABR is needed as a glue record, so that routers can ‘anchor’ the unknown ASBR RID against as reachable via a well-known node, the local ABR.

I hope this was informative and thank you for viewing.

Understating Cisco IOS v15 Licensing

IOS 15 is a single software package for the hardware platform that your are using. Now that flash is cheap and large, there doesn’t need to be a different IOS image for the different versions with the advanced features. So you get one software image that has all the features for that platform.

Prior to IOS 15 , we used to have 8 IOS images, all routers came with IPBase image and according to your needs you can choose what IOS image to install on your router as each image had different features than others as illustrated below.

wilkins_iosver_fig03 Read the rest of this entry

Use of EEM Scripting for Special Hot Backup Solutions

In this blog I would like to share some information about some special Hot backup solutions that we are forced to deal with due to customer requirements.

EEM.jpg

In the above figure, we have a customer that’s connected to the ISP through 2 Links, the Main link is a Pre-WiMax connection that’s carrying customer’s Internet and VPN traffic and configuration on the PE router is as below.

PE#show run int Fast1/0.100
Building configuration…
Current configuration : 184 bytes
!
interface FastEthernet1/0.100
description “Main Internet Link Pre-WiMax”
encapsulation dot1Q 100
ip address 190.200.200.1 255.255.255.0 secondary
ip address 172.16.1.1 255.255.255.252
end

PE#show run int Fast1/0.200
Building configuration…

Current configuration : 156 bytes
!
interface FastEthernet1/0.200
description “Main VPN Link Pre-WiMax”
encapsulation dot1Q 200
ip vrf forwarding VPN-A
ip address 172.17.1.1 255.255.255.252
end Read the rest of this entry